This course will become read-only in the near future. Tell us at if that is a problem.

Installing Python

installed python 3.4 on xpsp3

We first need to make sure that Python is installed on your Operating System of choice.

Follow the Instructions at

You can either Install Python 2.x or Python 3.x

  • Python 2.x is widely used and supports many frameworks and packages.
  • Python 3.x is the future and will soon replace 2.x.
  • For more information on whether to choose Python2.x or Python 3.x, visit:


Reply to this task with the following information:

  • Your Operating System
  • The version of Python that you have installed (2.x or 3.x)
  • Something you are excited to learn about in this class.

Alternative Resources

Task Discussion